Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi,

1. Just wondering if any other 2014 R/T owners were experiencing this. It appears to be coming in where window meets the rubber. If that makes sense. They've replaced the strips and it helped some, but I still get some noise.

2. At 80mph I get a sort of whistle.. anyone?

Thanks in advance!
AJ:4-dontknow:
 

·
Administrator
2016 Challenger Scat Pack Shaker
Joined
·
53,653 Posts
The only time I get any noise is if the passenger side window is not up all the way, it does not take much of a gap, just a hair and there is noise.Just noticed you have a 2014 with the 8 speed?
 

·
Registered
Joined
·
600 Posts
Hi,

1. Just wondering if any other 2014 R/T owners were experiencing this. It appears to be coming in where window meets the rubber. If that makes sense. They've replaced the strips and it helped some, but I still get some noise.

2. At 80mph I get a sort of whistle.. anyone?

Thanks in advance!
AJ:4-dontknow:
You should have ZERO wind noise, all I hear is the engine at 100 MPH.
And how did you get the 8-speed with a 2014? Do you have connections!!!!
 

·
Longing for spring
Joined
·
2,215 Posts
I dont know if this apply to your problem but i had that wind-noice on my 2009 to, driving me nuts. Simple fix, it was that little black triangular-shaped plastic thing on the lower front of the passenger-window who had moved up a bit and the wind was leaking in.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
The only time I get any noise is if the passenger side window is not up all the way, it does not take much of a gap, just a hair and there is noise.Just noticed you have a 2014 with the 8 speed?
6speed, obviously hit the wrong selection there. :)
Thanks... windows appear to be all the way up and the dealer already replaced the tracks. Better, but still get noise.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I dont know if this apply to your problem but i had that wind-noice on my 2009 to, driving me nuts. Simple fix, it was that little black triangular-shaped plastic thing on the lower front of the passenger-window who had moved up a bit and the wind was leaking in.
I'll check that out! Thanks!
 

·
Registered
Joined
·
600 Posts
6speed, obviously hit the wrong selection there. :)
Did you hit the wrong selection again? Now it says you have an Auto, which is a 5-speed!!!
 

·
What's Old is New Again!
Joined
·
39,516 Posts
Just a suggestion. Take your car through a touchless car wash with your blower fan tuned on to at least midway. When the wash starts soaping down the car, watch around the perimeter of the window for larger bubbles. That should be your leakage and the source of your wind noise.
 
1 - 9 of 9 Posts
Top