Dodge Challenger Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi all,
I’ve got a 2015 r/t with the 8.4 radio w nav and sirius etc. I hate not being able to upgrade to car play with the uconnect software and radio hardware so thinking of just buying a new whole radio unit for the 2016-current models so I can get the car play feature. Is that all there is to it? Just pop the old one out and install the new one? I understand there’s a USB media hub converter piece i’d have to get but everything else should be plug and play? Everything else should work as far as heated/cooled seats etc?

Thanks in advance!
 

·
Premium Member
Joined
·
2,259 Posts
Don't have the answers but interested in the answers you get as well?
 

·
Registered
Joined
·
2,735 Posts
Also interested in the answer
 

·
Registered
Joined
·
19 Posts
The radio is plug and play but if you have a 2015 you will lose your heated/cooled seats, heated steering wheel, and sport mode. the way to get them back is to buy a new 2016+ Body Control Module and have the dealer program it for your car. I just had it done and everything works fine with the new BCM.
 

·
Registered
Joined
·
26 Posts
i did the upgrade from the 5 inch radio on my 17 challenger to the 19 uag 7 inch radion since i was just looking for car play and got the unit pretty cheap. I just picked the dual usb hub but having issues in getting car play to work. on my phone it says to unlock iPhone for play but when i unlock no car play icon pops up on the head units. going to do a fuse to reset everything and see it rebooks the unit.
 

·
Registered
Joined
·
10 Posts
The radio is plug and play but if you have a 2015 you will lose your heated/cooled seats, heated steering wheel, and sport mode. the way to get them back is to buy a new 2016+ Body Control Module and have the dealer program it for your car. I just had it done and everything works fine with the new BCM.
woah! really? can you give me the part number you used?
 

·
Registered
Joined
·
10 Posts
Attached is my BCM part number I'm using.
Awesome thanks man. Yeah I lost sport mode, heated seats, heated steering, and my back up cam when I upgraded my radio this week. So I should just be able to order this and get a dealership to program it and throw it in?

Have you had any issues pop up after the upgrade?
 

·
Registered
Joined
·
19 Posts
Awesome thanks man. Yeah I lost sport mode, heated seats, heated steering, and my back up cam when I upgraded my radio this week. So I should just be able to order this and get a dealership to program it and throw it in?

Have you had any issues pop up after the upgrade?
I installed it myself and used alfaobd to program it enough to get it to run, it learns the new VIN automatically but I had to have it initialize with the Occupational Restraint System which is what I needed the Dealer for. You may be able to get them to install it but a lot of dealers won't if there isn't anything wrong with your existing one. I told them that my old one was diagnosed to be bad and I have a new one installed, just need to have it programmed to my vehicle, they didn't ask any questions and just did it.

No issues, one thing that half works is the launch control, you can enable it and use it but I can't change the launch RPMs, not a big deal to me.
 

·
Registered
Joined
·
10 Posts
Attached is my BCM part number I'm using.
Awesome thanks man. Yeah I lost sport mode, heated seats, heated steering, and my back up cam when I upgraded my radio this week. So I should just be able to order this and get a dealership to program it and throw it in?

Have you had any issues pop up after the upgrade?
I installed it myself and used alfaobd to program it enough to get it to run, it learns the new VIN automatically but I had to have it initialize with the Occupational Restraint System which is what I needed the Dealer for. You may be able to get them to install it but a lot of dealers won't if there isn't anything wrong with your existing one. I told them that my old one was diagnosed to be bad and I have a new one installed, just need to have it programmed to my vehicle, they didn't ask any questions and just did it.

No issues, one thing that half works is the launch control, you can enable it and use it but I can't change the launch RPMs, not a big deal to me.
I can live with half-working launch control. I think I'm gonna do the same thing. What OBD interface are you using OBD key?
 

·
Premium Member
Joined
·
2,259 Posts
You should have bought the BCM through a dealers service department and had them install and program it, because the BCM is one of the cars actual mileage recorders, the 2nd recorder of mileage being the ECM. If the BCM is not handled by a dealer your car is red tagged as the mileage being inaccurate. When you attempt to trade in that car your vin # will report inaccurate mileage to any dealership diagnostic reader, that's why you need that specific component dealt with Dodge taking full responsibility.

Finding this information written and documented is like finding a needle in a haystack on the internet, this is more or less what I've been told by Dodge service, so take it as you will, and if I am in error please link proof that what I am saying is wrong. Ry
 

·
Registered
Joined
·
19 Posts
Awesome thanks man. Yeah I lost sport mode, heated seats, heated steering, and my back up cam when I upgraded my radio this week. So I should just be able to order this and get a dealership to program it and throw it in?

Have you had any issues pop up after the upgrade?

I can live with half-working launch control. I think I'm gonna do the same thing. What OBD interface are you using OBD key?

I use BAFX, like 22.00 on Amazon.
 

·
Registered
Joined
·
19 Posts
Update: Got the BCM and had the dealer flash it, sport mode and heated seats are back! However, still don't have backup camera. Any Ideas?
great news! the backup cam not working is weird, you can try doing a complete reset by disconnecting the battery leads, hold them together for 30 seconds to discharge the capacitors, reconnect them close the trunk, hit the lock on the remote then leave it for 10-20 minutes for the BCM to learn everything on the CANBUS and try it again. some have said it took overnight before it started working but I have never personally experienced it taking that long.

if you have the alfaobd app you can go in and make sure that the "VehConfig 1-Rear View Camera", "ECUConfig 3-Rear Camera Present" didn't switch to disable for some weird reason. Also to put a Camera button on the screen so you can enable the camera manually, enable "CustSetMenu 1-Rear camera CSM" and it should give you a camera button.
 

·
Registered
Joined
·
10 Posts
great news! the backup cam not working is weird, you can try doing a complete reset by disconnecting the battery leads, hold them together for 30 seconds to discharge the capacitors, reconnect them close the trunk, hit the lock on the remote then leave it for 10-20 minutes for the BCM to learn everything on the CANBUS and try it again. some have said it took overnight before it started working but I have never personally experienced it taking that long.

if you have the alfaobd app you can go in and make sure that the "VehConfig 1-Rear View Camera", "ECUConfig 3-Rear Camera Present" didn't switch to disable for some weird reason. Also to put a Camera button on the screen so you can enable the camera manually, enable "CustSetMenu 1-Rear camera CSM" and it should give you a camera button.
I think I might let it sit overnight, now I still don't have backup camera but sport mode and seats have disappeared :-( I gotta wait until the bluetooth OBD2 part gets here before I can play with Afla.

I think it might be the ides of March
 

·
Registered
Joined
·
19 Posts
I think I might let it sit overnight, now I still don't have backup camera but sport mode and seats have disappeared :-( I gotta wait until the bluetooth OBD2 part gets here before I can play with Afla.

I think it might be the ides of March
did anything come back? that's odd that sport mode and seats disapeared on you.
 

·
Registered
Joined
·
10 Posts
did anything come back? that's odd that sport mode and seats disapeared on you.
Perf pages, heated/vented seats, and heated wheel control did come back. The backup cam (and reverse lights) did not come back (not sure if the reverse lights ever worked with new radio). Also noticed on a drive today Sport mode does come up but the flag icon doesn't appear and I have to manually press the traction control. weird right?
 
1 - 20 of 25 Posts
Top