Dodge Challenger Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
HEY GANG,

Wanted to throw this on here to see if anyone has any insight or if anyone has encountered any issues like this before. bare with me, I'll try to keep it as short as possible.

A couple weeks backs, as I was driving, my Uconnect "5.4 inch Standard" radio rest itself, when it turned back on the screen would not get past the Dodge Loading screen. Funny thing is you can still listen to the last radio station you had on before the initial crash. It's still crashed till today, every 10 to 15 minutes. I took it to the dealer and they informed me that the radio had to be replaced as it was faulty.

Now the real issue, a few days after the radio started to malfunction my A/C started having an issue were cold air stops blowing. When I start my car in the am or after it's been sitting for a couple hours, the A/c works fine and blows cold air. That last between 10 to 15 minutes, before cold air stops flowing and all I get is warm air. So the A/c pretty much blows cold air then to hot air the back to cold and so on, consistently.

I figured I had a freon issue, so I took the car to the A/c shop for a diagnostic. WHAT DO YOU know GOOD NEws, apparently there is nothing wrong with my A/c. freon levels is great, power to my compressor and all over systems are good.

The only suggestion the experts provided was that the A/C issue maybe caused by the faulty Uconnect (radio) since the Uconnect (radio) is what helps control the compressor. That the radio could be causing the compressor to shut of and shut on sporadically.

My next step is to replace my radio but I wanted to know if anyone has encountered this issue in the past.
 

·
Registered
Joined
·
148 Posts
HEY GANG,

Wanted to throw this on here to see if anyone has any insight or if anyone has encountered any issues like this before. bare with me, I'll try to keep it as short as possible.

A couple weeks backs, as I was driving, my Uconnect "5.4 inch Standard" radio rest itself, when it turned back on the screen would not get past the Dodge Loading screen. Funny thing is you can still listen to the last radio station you had on before the initial crash. It's still crashed till today, every 10 to 15 minutes. I took it to the dealer and they informed me that the radio had to be replaced as it was faulty.

Now the real issue, a few days after the radio started to malfunction my A/C started having an issue were cold air stops blowing. When I start my car in the am or after it's been sitting for a couple hours, the A/c works fine and blows cold air. That last between 10 to 15 minutes, before cold air stops flowing and all I get is warm air. So the A/c pretty much blows cold air then to hot air the back to cold and so on, consistently.

I figured I had a freon issue, so I took the car to the A/c shop for a diagnostic. WHAT DO YOU know GOOD NEws, apparently there is nothing wrong with my A/c. freon levels is great, power to my compressor and all over systems are good.

The only suggestion the experts provided was that the A/C issue maybe caused by the faulty Uconnect (radio) since the Uconnect (radio) is what helps control the compressor. That the radio could be causing the compressor to shut of and shut on sporadically.

My next step is to replace my radio but I wanted to know if anyone has encountered this issue in the past.
Hi Eperez1513, We sincerely regret to hear of your trouble however, glad to hear you are working with your dealer for this concern. If we can be of any additional assistance as you are working with your dealer, feel free to send us a private message. We'd be more than happy to help.
Rob
DodgeCares
 
1 - 2 of 2 Posts
Top