Dodge Challenger Forum banner

1 - 20 of 23 Posts

·
Business
Joined
·
20,621 Posts
Discussion Starter #1
Has anyone had problems with their backup camera going bad? My wife's 2017 Challenger SXT backup camera keeps taking a crap. She jus had it replaced last June. Over the weekend we jumped in the car to run some errands and again nothing but green with lines. I'm not going to keep replacing cameras! The car does sit outside but still the shouldn't be going bad like this. Fitting to file a complaint with dodge!
 

·
How fa$$$t do want to go?
Joined
·
8,481 Posts
That sucks! ...They may have replaced the first camera with a refurbished unit (from their supplier). Not uncommon practice (per the tech that replaced my radio the second year of ownership).
 

·
Business
Joined
·
20,621 Posts
Discussion Starter #3
That sucks! ...They may have replaced the first camera with a refurbished unit (from their supplier). Not uncommon practice (per the tech that replaced my radio the second year of ownership).
This will be the third camera going in her car. Going to do it this time myself. Maybe I'll spot the problem if there is one.
 

·
Waiting for beautiful fall colors!
2016 Go Mango Scat Pack
Joined
·
27,163 Posts
Good luck with this Jeff. I have a lot of mixed feelings about a back up camera. I like it sometimes, but then when I get in another vehicle without one, I worry about not looking properly while backing up! Hard for me to change old habits!!!
 

·
The Baron
Joined
·
585 Posts
I've never had an issue in 60k miles of 115F heat, rain, hail, and snow.

It's not a very complicated part, with very limited modes of failure. I'd certainly consider a DIY replacement to ensure everything is properly weatherproofed. Follow the wiring harnesses through the trunk to see if you can spot the failure.
 

·
Registered
2016 Dodge Challenger R/T Plus in Granite Crystal Metallic
Joined
·
1,643 Posts
Has anyone had problems with their backup camera going bad? My wife's 2017 Challenger SXT backup camera keeps taking a crap. She jus had it replaced last June. Over the weekend we jumped in the car to run some errands and again nothing but green with lines. I'm not going to keep replacing cameras! The car does sit outside but still the shouldn't be going bad like this. Fitting to file a complaint with dodge!
My aftermarket camera in my Ram goes blank occasionally. Just needs a reboot and it's fine. Keep us updated on your findings.
 

·
Business
Joined
·
20,621 Posts
Discussion Starter #7
It's been the same both times it went bad. Here's a picture of it.
20190429_163148.jpg

With it being the same. There has to be something some where whether it's in the wiring or water infiltration I will find it!
 

·
The Baron
Joined
·
585 Posts
It's been the same both times it went bad. Here's a picture of it.
View attachment 179582
With it being the same. There has to be something some where whether it's in the wiring or water infiltration I will find it!
The fact that the backup lines are distorted makes me believe this could be a connection issue. I'd check the back of the radio and take a look at the connectors. I don't know which one corresponds to the camera, but I do know that there is a specific connector with several wires for power, data, and guidelines.

Is this not within warranty anymore? It sounds like you have a lot of digging to do. You will introduce a bunch of rattles if you start pulling trim pieces to follow the wiring, believe me.
 

·
Business
Joined
·
20,621 Posts
Discussion Starter #9
The fact that the backup lines are distorted makes me believe this could be a connection issue. I'd check the back of the radio and take a look at the connectors. I don't know which one corresponds to the camera, but I do know that there is a specific connector with several wires for power, data, and guidelines.

Is this not within warranty anymore? It sounds like you have a lot of digging to do. You will introduce a bunch of rattles if you start pulling trim pieces to follow the wiring, believe me.
Out of warranty. Only has life time drive train warranty left.
 

·
Registered
2016 Dodge Challenger R/T Plus in Granite Crystal Metallic
Joined
·
1,643 Posts
Out of warranty. Only has life time drive train warranty left.
I would start in the back. Unplug the camera at it's closest connect to the actual camera, then plug it back in and see if that helps. From what it looks like it is a connection issue.
 

·
Registered
Joined
·
3,769 Posts
Check your AI ;)
 
  • Like
Reactions: nunya

·
Now that was dumb!
Joined
·
6,003 Posts
This will be the third camera going in her car. Going to do it this time myself. Maybe I'll spot the problem if there is one.

Jeff very good idea! Evidently those who replaced your camera are idiots. Ones who do the same thing time after time and get the same unfortunate results.
 

·
Registered
Joined
·
923 Posts
Try a different brand camera,my camera would goes dark on very hot(100 +) days so got one from Amazon and no more dark days- - - - -
 

·
The Baron
Joined
·
585 Posts
Try a different brand camera,my camera would goes dark on very hot(100 +) days so got one from Amazon and no more dark days- - - - -
I want to replace my camera with something that looks like it's from 2015, not from the moon landing.

My 2012 BMW is great. I've forgotten an item at the drive-thru, and can read the menu from the cashier's window through the backup camera. Pathetically humorous.

If I do swap for a new backup camera, I'll likely add a front and side one through the Tazer integration. I'll do a write-up.
 

·
Registered
2016 Dodge Challenger R/T Plus in Granite Crystal Metallic
Joined
·
1,643 Posts
I want to replace my camera with something that looks like it's from 2015, not from the moon landing.

My 2012 BMW is great. I've forgotten an item at the drive-thru, and can read the menu from the cashier's window through the backup camera. Pathetically humorous.

If I do swap for a new backup camera, I'll likely add a front and side one through the Tazer integration. I'll do a write-up.
Let me know if you add the front. I was thinking of the same. Just did an aftermarket setup in my Ram, I love it.
 

·
Registered
Joined
·
13 Posts
2017 T/A (bought in July 2017) --- from day one, my camera has been hit & miss during wet/rainy weather. I'll either get a blue screen, or a very very dark video/image (that will flicker on & off).

Is this a known problem with the Challengers? When I wash my car, I pretty much know the camera is going to be half-ass for 12+ hours.
 

·
Registered
Joined
·
13 Posts
2017 T/A (bought in July 2017) --- from day one, my camera has been hit & miss during wet/rainy weather. I'll either get a blue screen, or a very very dark video/image (that will flicker on & off).

Is this a known problem with the Challengers? When I wash my car, I pretty much know the camera is going to be half-ass for 12+ hours.
Recent update --- for the first time since purchase, couldn't get camera/video for multiple days. Instead of a 24-hour hit & miss cycle (as the car was drying-out), the display flat-out didn't work for 7+ days. I got the blue-screen with "Camera System Unavailable."

So I tried some minor trouble-shooting. Re-boot of radio, pulled the camera fuse, and jiggled the camera wires. Did *not* remove the spoiler (my car is still under Warranty, so I didn't want to tinker too much).

Didn't fix the problem.............and then, about 48 hours later (after 4-5 trips to/from home), magic, the camera was fine.

No clue. Either the camera/connections finally got dry enough, or it took a few cycles for my trouble-shooting to "click" with the camera system.
 

·
Registered
Joined
·
1 Posts
I have an 2018 challenger sxt plus. The backup was working then i turn off the car for 10 min and when i turn it on again camera was not showing up on the screen i can still see u connect and car play on reverse gear
 

·
Registered
2014 Boosted 392 Stroker Shaker
Joined
·
3,391 Posts
I don't have one, and I don't need one. My trick is to turn around and look where I'm going. It works much better than using mirrors...
 
1 - 20 of 23 Posts
Top