Dodge Challenger Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just changed the oil in my 2015 challenger. I've checked repeatedly for leaks but there are none. since I've changed it the low oil pressure light and check engine light have been on. it's idling oil pressure is extremely low around 3-4 psi. I don't understand what problem may be in sure I'm missing something simple and help would be greatly appreciated.
 

·
Premium Member
Joined
·
12,625 Posts
Welcome to the Z from WV... Glad you joined us.... Sounds to me like you need to make a trip over to you dealer. I guess my question is have you driven the car with the low oil pressure? Your car is a 2015 you still have towing coverage to get it to the dealer to get it checked out.
 
  • Like
Reactions: BAD GRANDPA

·
What's Old is New Again!
Joined
·
39,859 Posts
Sounds to me like you may not have put enough oil in it(Hemis take 7 qts) or you may have a defective oil filter.
 

·
What's Old is New Again!
Joined
·
39,859 Posts
I'm confused here. ryan26, you have an R/T listed as your Challenger model, which should have the Hemi. The Hemis take a screw on filter. The filters pictured above are for the V6.
 
  • Like
Reactions: BAD GRANDPA

·
Premium Member
Joined
·
2,306 Posts
My guess would be a faulty oil-pressure sensor. HOWEVER, since we are talking about the lifeblood of your car's engine, you need to take it to a shop to have it tested. I had a bad sensor in another car (a Pontiac) which would read really low pressure at idle. I had it checked immediately.
 

·
What's Old is New Again!
Joined
·
39,859 Posts

·
Registered
Joined
·
154 Posts
When I first got my car I changed the oil to Royal Purple. My sensors said oil pressure was too high. Turned out to be a faulty sensor.
 
1 - 13 of 13 Posts
Top