Dodge Challenger Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have my '10 SRT manual which I have had for a while. Haven't had any problems with the clutch so far but it is nearing 65k miles. So I will press the clutch all of the way to the floor and go to shift into reverse. It feels like the stick grinds, but when the grinding finally slows to no grind, it goes into reverse. I have also had a similar problem getting into other gears as well. I'm just wondering what exactly could be wrong with it?
 

·
Registered
Joined
·
229 Posts
clutch

I had the same problem with my 09 srt with 10,000 mi on it last year the dealer ended up droping the drivetrane out of the car to replace some grease on a spline in there. if your not hard on the clutch this might be the problem. there is a thread on this problem in here somewere.
 

·
Premium Member
Joined
·
39,846 Posts
I had the same problem with my 09 srt with 10,000 mi on it last year the dealer ended up droping the drivetrane out of the car to replace some grease on a spline in there. if your not hard on the clutch this might be the problem. there is a thread on this problem in here somewere.
Here is the thread. http://www.challengerforumz.com/showthread.php?t=70227

It doesn't mention the grease problem until you get a little way into it.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top