Dodge Challenger Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
I have a 2014 Dodge Challenger with the keyless entry, one day (after taking the car to get an alignment at a local tire shop) the keyless entry stopped working. The car doesn't recognize my key fob at all, and I have to pull out the push-button start and use the key fob manually to start the car now, as well.

The error message I get says "Damaged Key" but when I try my other key fob (which I got with the car new, never used), it says the same thing. I switched out the batteries in both fobs, didn't make a difference. Same error message for both fobs.

I called a local shop that does keys for cars, they said to pull the fuse and also to pull the battery for 30 minutes and let the computer reset, and everything should be fine. Neither worked, still getting the same error message. Had three local shops then tell me that it is something with the PDC computer or WIN module, and I need to take it to the dealership (which has been on a month-long wait list).

I have an appointment with the dealer, but they told me that they have to make two new key fobs (at my expense) before they can troubleshoot anything further. Another person at the dealership said to take it in and they will just take it from there. I have two friends locally (one with a Jeep, one with a Dodge) that have been having the same issues at the same time. Not sure if this is a TSB of some sort, but wondering if anybody else has recently had this issue and what they did to fix it?
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #3 ·
Mine is not involved apparently, but it should be. Can anybody please send me that recall so I can at least take it to the dealership and try to get mine covered, please?
 

·
Registered
Joined
·
339 Posts
Both key fobs wouldn't work intermittently but never a damaged key message. Ended up changing the car battery (4 1/2 years old) and that seems to have greatly improved things but on occasion there still seems to be glitches. Did ask if there was a quick accurate way to check the ignition node condition but as it is a dealership I'm sure they have figured out a way to charge an hours labour at least and just check if it is working in the moment.
 
1 - 8 of 8 Posts
Top