Dodge Challenger Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
I have a 2010 R/T with a diablo tune, k&n cai and Borla atak cat back. I live in Illinois and twice ive gone for emissions and both times it came up my o2 and catalytic converter not ready. After the first time I set the diablo back to the factory settings and drove it about 300miles with the same results at the emissions place. I unplugged the battery for 30 min and set the tune back to the cai and octane and they are still showing not ready. I have temporary tags and only a couple weeks to get this fixed. How do I fix this??? Please help
Thanks
 

·
Registered
Joined
·
12,271 Posts
I think you need to have several on/off cycles for the car more so than miles after clearing codes or resetting. When you clear codes (disconnect battery) the car needs to go through three on/off cycles to be sure there are no codes. I believe a CEL will not show unless the fault is detected three times. With that said, the car is 'not ready' until it has processed data for three cycles.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #3 ·
by three on/off cycles do you mean literally turn it on and off because it has been both several times before each incident
 

·
Registered
Joined
·
614 Posts
Just curious here, but does the car have long tube headers and are cats installed?
 

·
Registered
Joined
·
60 Posts
I know this is of little help but I LOL'ed when I saw you were in the People's Republic of Illinois. Because upon reading the title of the thread I said I bet this person is in either California or Illinois. And I was right.

Good luck.
 

·
Registered
Joined
·
614 Posts
Illinois is not near as bad as CA, trust me I know both...:D
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #8 ·
The tags are temporary because I can not renew them until I pass emissions. I am the original owner and the only mods are the ones mentioned. Yes Im in Illinois and have been told many times I would be better off pretty much anywhere but California
 

·
Registered
Joined
·
380 Posts
The tags are temporary because I can not renew them until I pass emissions. I am the original owner and the only mods are the ones mentioned. Yes Im in Illinois and have been told many times I would be better off pretty much anywhere but California
Did you go down Orchard road through Oswego saturday ? I saw a sharp black one with some cool headlight covers or something in the grill and temp tags on it. Sorry about your emissions and sorry for going off topic.
 

·
"Gin'iro Ryuujin"
Joined
·
2,363 Posts
I have a 2010 R/T with a diablo tune, k&n cai and Borla atak cat back. I live in Illinois and twice ive gone for emissions and both times it came up my o2 and catalytic converter not ready. After the first time I set the diablo back to the factory settings and drove it about 300miles with the same results at the emissions place. I unplugged the battery for 30 min and set the tune back to the cai and octane and they are still showing not ready. I have temporary tags and only a couple weeks to get this fixed. How do I fix this??? Please help
Thanks
Check for exhaust leaks. Check and or replace your O2 sensors. Check the wiring to the O2 sensors. You may have a leak someplace. This may help you check potential problem areas: http://www.obd-codes.com/p2096
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top