Dodge Challenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Has anyone had this problem with the ESP BAS light coming on and staying on? Also, it basically comes on and off when it wants to... I've taken it to the dealer and they told me that the "STEERING CONTROL MODULE NEEDS TO BE REPLACED". This part cost $718.00 by itself. Has anyone experienced this problem?
 

·
Dazed & Confused
Joined
·
35,477 Posts
Really? Yours was a bad wheel sensor? Was your PSI readings acting funny? Such as misreads or something like that?
Was not the pressure sensors in the tires, was one of the wheel speed sensors. Lights came on, then went off for days. Was intermittent until I was on my way to the shop and they came on for good. Did not throw a CEL either.
 

·
Dazed & Confused
Joined
·
35,477 Posts
It's one of the only things that causes all those light to come on. I carried it to a friends shop and he checked it with their scanner. Charged me $45 to change it out (parts & labor).
 

·
Registered
Joined
·
38 Posts
Discussion Starter #7
I believe mine threw up a code while at the dealer but, it did not point towards the speed sensor. Here are the codes I believe if that means anything to you... Code C2205 and Code C121A
 

·
Dazed & Confused
Joined
·
35,477 Posts
Mine did not throw any codes when the wheel sensor went out but Googling those codes show a problem with the steering angle sensor which I believe is the same thing in your 1st post.
 
1 - 8 of 8 Posts
Top