Dodge Challenger Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Glad to be a member. I have a 2010 Wrangler Sahara Unlmtd with a 720N RER MyGIG. The touchscreen has stopped working. Is there a solution or fix?
 

·
Registered
Joined
·
2,577 Posts
Welcome to the Z from Maryland. Enjoy the site.

I don't have any help for you, but I'm sure somebody will chime in.
 

·
Registered
Joined
·
22,643 Posts
Welcome to the forum.
 

·
What's Old is New Again!
Joined
·
39,460 Posts
Hello from Strasburg, Va

Hello and Welcome to the 'Z' from the beautiful Shenandoah Valley of Virginia. :4-wavey: Enjoy your Ride and the Site! You'll find some knowledgeable and friendly people to answer your questions or just entertain you. Glad you could join us!

You may want to try disconnecting the negative battery cable. Other than that try one of the audio vendors in the supporting vendor section.
 

·
Registered
Joined
·
383 Posts
Welcome to the ForumZ from FL!
It's good to have you with us, thanks for joining.
 

·
Administrator
2016 Challenger Scat Pack Shaker
Joined
·
53,567 Posts
Welcome from AZ.
 

·
Senior Member
Joined
·
12,989 Posts
Welcome from north N.J.
 

·
<<< Bending Time & Space >>>
Joined
·
16,093 Posts
:Racing: Hello and Welcome from Wyandotte Michigan !!! :Racing:
 

·
Registered
Joined
·
444 Posts
Welcome to the Z forum from Atlanta Georgia..............enjoy. Sorry I cant help you with your issue, but I am sure someone will point you in the right direction
 

·
Seeing red
Joined
·
14,951 Posts
Welcome to the Z from New Mexico! You have found the absolute best spot for a Challenger lover to be except for behind the wheel!
 

·
Registered
Joined
·
3,142 Posts
Welcome to the Z from Northern California. Come on in for the best help, food for thought, and conversation there is to find anywhere. Life is GOOD with a Challenger! Glad you're here. :smileup:
 
1 - 20 of 20 Posts
Top