Nav radio problems

Discussion in 'Dodge Challenger GT AWD Forum' started by hippy, Dec 6, 2017.

  1. hippy

    hippy New Member

    Joined:
    Aug 25, 2017
    Messages:
    27
    Likes Received:
    36
    Gender:
    Male
    Location:
    USA
    Vehicle?:
    Challenger GT
    Model Year?:
    2017
    Trim?:
    GT
    Color?:
    Green Go
    Transmission?:
    8-Speed Auto
    My Nav radio has had issues since day 2 of ownership. I haven't gotten around to taking it in yet but will be pretty soon. The radio either, locks up where no buttons work, freezes while playing a song and just humming the same part of the song or the screen is black with an x in the upper right had corner. Anyone else had issues with their radios? Is the fix a firmware issue or hardware issue if you had it fixed?
     
    wvhemis likes this.
  2. BeastieOwner

    BeastieOwner Member

    Joined:
    Jan 27, 2017
    Messages:
    353
    Media:
    2
    Likes Received:
    584
    Gender:
    Male
    Location:
    Fresno Ca
    Vehicle?:
    Challenger SRT
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto
    Have you called UConnect? they can help you reboot and also check out the radio unit..
     
  3. hippy

    hippy New Member

    Joined:
    Aug 25, 2017
    Messages:
    27
    Likes Received:
    36
    Gender:
    Male
    Location:
    USA
    Vehicle?:
    Challenger GT
    Model Year?:
    2017
    Trim?:
    GT
    Color?:
    Green Go
    Transmission?:
    8-Speed Auto
    I have not, didn't know that was an option.
     
  4. BeastieOwner

    BeastieOwner Member

    Joined:
    Jan 27, 2017
    Messages:
    353
    Media:
    2
    Likes Received:
    584
    Gender:
    Male
    Location:
    Fresno Ca
    Vehicle?:
    Challenger SRT
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto
    Sure is, no guarantee it will cure the issue..
    But it’s wirth a try— not sure of your location, I’m in Ca and have called at 11pm and thro the night...L
     
  5. CtheW0rld

    CtheW0rld New Member

    Joined:
    Thursday
    Messages:
    12
    Likes Received:
    11
    Location:
    PA
    Vehicle?:
    Challenger
    Model Year?:
    2018
    Trim?:
    GT
    Color?:
    Bright White
    Transmission?:
    8-Speed Auto
    I got 60 hours of ownership before mine had to go into the shop. Screen backlight was on and wouldn't shut off. Called roadside assistance and they came out to jump it (battery had NOT gone dead). That fixed it but while I was on the way to work my gauges the screen between them went dark for a couple seconds. Long story short, took it to the shop and the said it needs a new radio. Not happy. I want them to give me an entirely different vehicle or cancel the deal because this is a known problem.

    I was THRILLED when I found out I could have a coupe with AWD that also looked good. Kinda regretting the decision, now. FWIW I traded in a 2011 Accord V6 coupe that served me without one single problem for 7.5 years.
     
  6. SmokinBob

    SmokinBob New Member

    Joined:
    Jun 22, 2017
    Messages:
    3
    Likes Received:
    11
    Gender:
    Male
    Location:
    Marysville Michigan
    Vehicle?:
    Challenger
    Model Year?:
    2017
    Trim?:
    GT
    Color?:
    TorRed
    Transmission?:
    8-Speed Auto
    I had a ton of problems with my Nav and backup camera once the car hit 500 miles. I took it into the dealer for a radio update and all problems were solved. I read the fix list for the update and every problem I was experiencing was listed as being addressed by the update.
     
  7. CtheW0rld

    CtheW0rld New Member

    Joined:
    Thursday
    Messages:
    12
    Likes Received:
    11
    Location:
    PA
    Vehicle?:
    Challenger
    Model Year?:
    2018
    Trim?:
    GT
    Color?:
    Bright White
    Transmission?:
    8-Speed Auto
    I've read on another forum the 2017s are a software problem whereas the 2018s are a hardware problem. The service manager at the dealership where i bought it said there is not a known fix, but they are getting approval to install a new radio.
     
  8. Clump

    Clump New Member

    Joined:
    Jan 2, 2017
    Messages:
    93
    Likes Received:
    234
    Gender:
    Male
    Location:
    Frederick, MD
    Vehicle?:
    2016 Challenger
    Trim?:
    R/T Scat Pack Shaker
    Color?:
    Granite Crystal
    Transmission?:
    6-Speed
    My GF bought a 2017 Jeep Compass with factory nav about a week ago. It's the new 2017 head unit. The nav never worked. It has a globe with the words "Navigation Loading", but it never goes any further.

    A reboot can be done by pressing the upper right corner of the screen for 10 seconds. Made no difference. Disconnected the negative battery cable for over an hour - no difference.

    UConnect support was completely useless. They had me trying to get into the engineering menu from the old system.

    The dealer has supposedly ordered a new head unit, but we're getting conflicting stories from them and Jeep customer care. Latest is it's supposed to be in on the 12th.

    Obviously this system was not ready when they released it. It was an expensive option ($895) on the Compass that probably left the factory not working and was delivered by the dealer not working.
     

Share This Page