Dodge Challenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,105 Posts
Discussion Starter #1
Hey guys I am having an issue and need help narrowing it down.
A week or so ago I get into the car and crank it and begin driving down the road and notice that my stereo isn't powering up. Then notice that the gps and cigarette lighter aren't working either. The traction control is in alarm and has the car with the skid marks is lite up also. In addition to this the wipers aren't working and the power windows are not either. Well when I get home I switch off car and switch back on and bam everything is fine. This has happened a couple times since. I am wondering if there is a relay that is powering all of these things and is going bad. BTW the head unit and GPS are powered from the lighter supply!
 

·
Registered
Joined
·
13,032 Posts
Man I have no clue where to start on that one. Sounds like a bad connection somewhere though, maybe something is loose somewhere. I had an issue with my power seats not working and it turned out to be just a loose connection under the passenger seat. It looked like it was fine and plugged in, but I shoved it on a little harder and then they worked fine.

Maybe you can pull up a wiring schematic online and check to see if any connections are easily accessible and if one or two of them control all of the things you were losing. Could just be something up under the dash somewhere near the firewall in the engine bay.
 

·
2012 RT Redline Tri Coat
Joined
·
3,675 Posts
Guys, this issue is well documented, especially on other Chrysler and Dodge vehicles. Its a computer and software issue and is rarely ever fixed. If you have a tuner, I suggest you use it. Another thing I would do is to disconnect the battery, let it sit for a few minutes and connect it again for a hard reboot.
 
1 - 4 of 4 Posts
Top