Dodge Challenger Forum banner
1 - 20 of 23 Posts
G

·
Discussion Starter · #1 ·
Hello everyone!
I have a 2012 Dodge Challenger, I just bought and I love it. I have some questions about it though. For some reason my check engine light keeps coming on, it has been to the dealership 4 times so far and its the same thing, a small evap leak. So they replaced my gas cap and a fuel filler tube?? and it still came back on.. Today I bought a new gas cap to see if that will help. Has anyone else experienced this issue??

Thanks for any assistance anyone can give me. :smileup::smileup:
 

·
Administrator
2016 Challenger Scat Pack Shaker
Joined
·
58,984 Posts
Welcome from AZ, have not seen this issue reported here either but somebody may chime in.
 

·
Premium Member
Joined
·
39,846 Posts
Hello from Strasburg, VA

Hello and Welcome to the 'Z' from the beautiful Shenandoah Valley of Virginia. :4-wavey: Enjoy your Ride and the Site! You'll find some knowledgeable and friendly people to answer your questions or just entertain you. Glad you could join us!


Sorry, I can't help you with ths one. Maybe someone will chime in.
 

·
Registered
Joined
·
430 Posts
Hello everyone!
I have a 2012 Dodge Challenger, I just bought and I love it. I have some questions about it though. For some reason my check engine light keeps coming on, it has been to the dealership 4 times so far and its the same thing, a small evap leak. So they replaced my gas cap and a fuel filler tube?? and it still came back on.. Today I bought a new gas cap to see if that will help. Has anyone else experienced this issue??

Thanks for any assistance anyone can give me. :smileup::smileup:
Welcome aboard from western Indiana. I am sorry that I can't help but I just got mine Monday and it doesn't have any issues. 2011 SRT8 Inaugural.
 
G

·
Discussion Starter · #6 ·
Wow

I am so surprised at how fast you guys reply, thank you so much for taking the time!! Hopefully someone can point me in the right direction..:smileup: Thanks again!!
 

·
Administrator
2009 Challenger R/T Auto
Joined
·
37,937 Posts
Welcome to the Z from NC! Yeah, it's usually a gas cap that causes that. Be sure to torque it down good. If it continues, may have a small leak at a hose someplace. Glad you joined, enjoy the site!
 

·
Andy
Joined
·
3,906 Posts
welcome to the Z from Sherwood Park, Alberta...hope you enjoy it and your new ride.

I would have guessed gas cap and it sounds like you have that covered...so not too sure. Hope you get an answer soon though...must be annoying.
 

·
Senior Member
Joined
·
13,007 Posts
Welcome from north N.J.
 

·
Politically correct.
'09 SRT 440 HEMI
Joined
·
11,890 Posts
Welcome to the Z from Pa.!!!! Enjoy the site and please keep us informed.

:4-wavey:
 

·
Seeing red
Joined
·
14,951 Posts
Welcome to the Z from New Mexico! You have found the absolute best spot for a Challenger lover to be except for behind the wheel! Enjoy the ride! If it is a gas cap issue, make sure you replace it with an OEM cap. I had a similar issue with a previous car and replaced the cap with an AutoZone-type one. The issue persisted until it was replaced with an OEM one.
 

·
<<< Bending Time & Space >>>
Joined
·
16,087 Posts
:Racing:Hello and Welcome from Michigan. Enjoy the forum !!!:Racing:
 

·
Registered
Joined
·
282 Posts
Welcome to the Z from Central Ohio

Definitely keep us posted as work to resolve the issue.
 

·
Registered
Joined
·
8,516 Posts
Hello and Welcome to the “Z” from Pittsburgh, PA! Congratulations to you on the Challenger! Not with my Challenger but my daily driver with sever weather changes. If I get impatient waiting for it to go off I open up the fuse panel under the hood look for the fuses or relays that deal with emission controls pull them for 30 seconds, reinsert, and the light goes away.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top