Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
i bought a 2014 redline hemi rt 2 weeks ago now question for the guys with the automatics i have the diablo tuner and disable the mds but still seems like its on around 40 ill let up on the gas and it feels like the breaks are being applied. and also its happened twice now ill back out of my driveway to leave and put it in drive and the car shakes like stutters then its fine is this normal? thanks guys
 

·
Registered
Joined
·
22,643 Posts
I'm fairly certain that if you turned MDS off with the diablo tuner that it is off. The eco light will continue to come on but it is actually off. As for the feeling of the brakes being applied that wouldn't be the MDS system, might be the car downshifting to hold you back on a downhill grade or if your car has sport mode it often runs in reduced gear to put you in a better spot along the power curve.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3 (Edited)
I have hill asst. off and it happens when I don't have sport mode on it just drags and downs shifts like it doesn't wanna coast maybe its just me since im coming from the 8speed charger to a 5 speed
 

·
Registered
Joined
·
413 Posts
I agree with Cuda. You would know when the MDS kicks on. Especially if you have an upgraded exhaust. You cant miss hearing it in the cabin, especially since the mufflets are right under the center of the car. You can turn off the ECO light via the EVIC. The light coming on has nothing to do with MDS. Usually it will light up when ur driving in granny mode. The the car letting you know you are ECOnomical. Lol.
 
1 - 5 of 5 Posts
Top