Dodge Challenger Forum banner

1 - 20 of 31 Posts

·
Founder
Joined
·
3,728 Posts
Discussion Starter · #1 · (Edited)
Post with confidence!

www.ChallengerForumZ.com is fully 2048bit SSL encrypted from your browser to the site. Post knowing your connection can not be monitored, sniffed, etc. We believe in your privacy, and respect completely your right to maintain it.

Data sent using HTTPS is secured via Transport Layer Security protocol (TLS), which provides three key layers of protection:
  1. Encryption — Encrypting the exchanged data to keep it secure from eavesdroppers. That means that while you are browsing the website, nobody can "listen" to your conversations, track your activities across multiple pages, or steal your information.
  2. Data Integrity — Data cannot be modified or corrupted during transfer, intentionally or otherwise, without being detected.
  3. Authentication — Proves that our members communicate with the intended website. It protects against man-in-the-middle attacks and builds user trust!

Thank you!
 

·
Registered
Joined
·
957 Posts
Thanks GT for taking the time to do that.
 

·
Premium Member
Joined
·
6,141 Posts
Every time I changes pages, bottom banner pops up stating only secure content is shown, gives option show all each time I change ? Did not have that happening before change?
 

·
Founder
Joined
·
3,728 Posts
Discussion Starter · #12 ·
@baggerjack Yes. I'm sorry about that.
There is some ad code in the background that is not secure. That doesn't mean anything though.
When the site is not using SSL, your browser doesn't bother to tell you that any single part isn't secure. But now that we are secure, your browser will warn you about every little thing.

I will be trying to eliminate all of those little issues as quickly as possible. But there is nothing to worry about.
 

·
Registered
Joined
·
3 Posts
SSL??? Wasn't that a Rambler designation from the last century? Their red white and blue drag car? What has that got to do with Hemis and the smell of fried rubber?
Anyway, thats great work and keep up the pace there soldier.
 

·
Premium Member
Joined
·
6,141 Posts
@baggerjack Yes. I'm sorry about that.
There is some ad code in the background that is not secure. That doesn't mean anything though.
When the site is not using SSL, your browser doesn't bother to tell you that any single part isn't secure. But now that we are secure, your browser will warn you about every little thing.

I will be trying to eliminate all of those little issues as quickly as possible. But there is nothing to worry about.
Looks like you took care of it -- it no longer pops up!!!
 

·
Founder
Joined
·
3,728 Posts
Discussion Starter · #19 ·
Guys this is a huge pain in the butt. We can't have it both ways.
If we are going to be secure, then all photos attached to threads must be uploaded into our own gallery, and never linked from someplace else.

If you upload to the gallery you can share the same image in multiple posts without having to re upload it to individual posts. It's a very nice feature.

Also, you are still able to attach to individual posts. But the gallery is by far, the preferred method.

Please do not use photo bucket any longer.
 

·
Founder
Joined
·
3,728 Posts
Discussion Starter · #20 ·
I set up the site to proxy images inserted into PAST posts from off-site hosts. This should keep the pages secure but from here on out our policy will be to host your images on this site and not use any off-site hosts. Pretty PLEASE! Thank you for your cooperation.

This will result in a much more fluid experience for everyone, and no images will ever be lost to broken links, deletion of off-site images. etc. etc. This is very important folks.
 
1 - 20 of 31 Posts
Top