Dodge Challenger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Wanted to give everyone an update, I have 4300 miles on my car now and unfortunately have to add another issue. I now have a vibration in the clutch pedal which gets worse as rpm increases, also noticed throw out bearing noise when idling. I have used Mobil 1 and Pennzoil Ultra in the engine, valve train noise did not change and probably got slightly worse over time. Rear diff. noise did get better for a very short time when I changed out the fluid but then came back.. Very sad that in 2014 quality control can't be better!
 

·
Registered
Joined
·
33 Posts
I had my 2014 R/T in for service with the valve train noise issue just this week. They said they replaced some retainers that had collapsed causing not enough oil to get to the top of the motor, hence the noise. It did quiet it down a bit, but not enough for my taste. Also to add insult to injury, they rolled a cam cover gasket causing an oil leak on the passenger side of the motor. The service tech was extremely embarrassed about this mistake and fixed it promptly the next day. As for the noise they brought another brand new challenger around to compare engine noise in the top end. It had a little bit of noise but not quite as loud as mine was. The service manager suggested at that point not breaking into the motor again, as it had plenty of warranty left, and visit it at a later date if it got worse. They also said that the injectors could be a lot of that noise. That is where I am with that situation.:4-dontknow: I also noticed a throw out bearing noise in my garage before I took it to the shop. The service advisor heard it too when I brought it in, but they couldn't get it to happen again after they got it in the shop and on the rack. I hope it don't come back. Other that that, I love my car, she's my baby, and just dripping with awesomeness. I hope I don't have to take her back to the hospital any time soon.
 
1 - 3 of 3 Posts
Top