Dodge Challenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Guys,
IM having trouble with my radio in my 2016 Dodge Challenger SXT. Everything I turn on my car the Dodge screen appears and stay on that screen until I turn offcar and open the door, then it goes off like normal. This started around 6 months ago and being so busy I did not have time to find out what was wrong. I called UConnect and they say update the program but when I key in my VIN DriveUconnect.com/system-update tells me there is no update for my vehicle. I also tried finding the original software but unfortunately had no luck. Someone please HELP!! Im like LL Cool J. “I CANT LIVE WITHOUT MY RADIO!!”
 

·
Administrator
2016 Challenger Scat Pack Shaker
Joined
·
54,846 Posts
Welcome from AZ. I would try a 15 minute disconnect of the negative battery terminal.
 
  • Like
Reactions: TITANIUM and nunya

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Welcome from AZ. I would try a 15 minute disconnect of the negative battery terminal.
Ive Tried That. I recently noticed that when uninstalling some aftermarket speakers/subs I accidentally cut the main gauge wire connecting to the wiring harness running into the back of my radio. What did these wires connect to originally. I believe this is my main problem at hand so if ANYONE is willing send me a picture of the back of their factory radio (that hasn’t been tampered with) Id greatly appreciate it. As of now I cant even get my air to blow out of the vents. As I stated earlier, Ny screen is coming on and going off as normal but when it comes on it stays on the dodge screen. THANX IN ADVANCE!!!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
This Is The Same Screen I’ve Been Seeing Since I Cut The Cords (I Believe) No Sound No Button Response on Steering Wheel our Wit Conditioning
70935433-9744-44D5-BC02-A440823938D9.jpeg
 
1 - 4 of 4 Posts
Top