Dodge Challenger Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I was in Africa on deployment and when I came back my 2019 Scat Pack (with standard trans) UConnect had updated itself. From reading the forums this seems to have happened in April. The Performance Page timers were one of the changes. Instead of showing separate pages for current, last, and best times it now shows all three on the same page. The problem I am having is that only the current data shows up on the new Performance Page timer screen. The last and best times no longer fill with the data but remain dashes. The center console screen between the tach and the speedometer do display the last and best data, but it can only be viewed one parameter at a time.

I verified on the UConnect website that my software is up to date. It gives me no option to download the current or a new version.

Disappointed that the 0-60mph timer was removed from the screen, replaced with time to 300ft distance data. There is the option to put the 0-60mph timer on the SRT home page.

Anyone else experiencing this problem? Any ideas to fix it?
 

·
Registered
Joined
·
258 Posts
I am having the same problem. If I set the display above the steering wheel to 0-60, and make a run, it will record and show on the U-Connect screen, but only current. If I go in a day or 2 later, they all show as dashes. NO current...NO Last...and NO Best. The new update messed it up. It's a bummer since I went to the Drag strip 2 weeks ago, and nothing was saving on the U-Connect. I did get a 3.5 0-60 though :)
 

·
Banned
Joined
·
43 Posts
There was an issue a month or 2 back where a new over-the-air Uconnect update was disabling the Performance Pages for some people (not everyone). Over on one of the forums, a guy found this work-around Press the uconnect apps button and open the uconnect store Remove uconnect subscription turn off car with FOB in Showbox jiofi.local.html tplinklogin hand, leave the area with the FOB for at least 30 seconds. turn vehicle back on and within 3 drive cycles the performance pages should return.
 

·
Registered
Joined
·
258 Posts
There was an issue a month or 2 back where a new over-the-air Uconnect update was disabling the Performance Pages for some people (not everyone). Over on one of the forums, a guy found this work-around Press the uconnect apps button and open the uconnect store Remove uconnect subscription turn off car with FOB in Showbox jiofi.local.html tplinklogin hand, leave the area with the FOB for at least 30 seconds. turn vehicle back on and within 3 drive cycles the performance pages should return.
Are you saying to turn the car off with the FOB, or turn off the car with the dash push button and have the FOB in the car? Also, I have the performance pages, but the "LAST" and "BEST" are not working. Is this fix for people's pages that aren't working at all, or for my situation?
 

·
Registered
Joined
·
1 Posts
Are you saying to turn the car off with the FOB, or turn off the car with the dash push button and have the FOB in the car? Also, I have the performance pages, but the "LAST" and "BEST" are not working. Is this fix for people's pages that aren't working at all, or for my situation?
Same issue on Trackhawk. You can return to the previous version of screens by doing a reset/erase user data. this will get you back to 180061. But the updated software will activate itself after a few starts and it will go to 190416. This gives you the new screen with Drag and Accel & Braking tabs but the Last and Best will only show lines....the data is still there and can be seen on the center dash display. A friend with a new 2021 trackhawk just reported the same issue.

So i guess we are stuck until some fix get delivered.
 

·
Registered
Joined
·
258 Posts
Same issue on Trackhawk. You can return to the previous version of screens by doing a reset/erase user data. this will get you back to 180061. But the updated software will activate itself after a few starts and it will go to 190416. This gives you the new screen with Drag and Accel & Braking tabs but the Last and Best will only show lines....the data is still there and can be seen on the center dash display. A friend with a new 2021 trackhawk just reported the same issue.

So i guess we are stuck until some fix get delivered.
So there really is no way of fixing it? I wonder what we can do to light a fire under someone's a$$ to fix it?????
 
1 - 6 of 6 Posts
Top