service shifter message in HUD

Discussion in 'Dodge Challenger Electrical Problems and Questions' started by silverhorse, Apr 17, 2016.

  1. silverhorse

    silverhorse Member

    Joined:
    Sep 7, 2009
    Messages:
    319
    Likes Received:
    258
    Gender:
    Male
    Location:
    Grand Rapids, MI
    Vehicle?:
    SRT 392
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto
    2016 srt...... anybody else getting this message? 5k on car w/ 8sp auto. Error popped up in hud during a drive yesterday and the first part of today..... stopped during last 2 hours of driving. Everything works fine. Popped up a few times during driving (Normal drive mode in "D" position) then goes away. I will be calling dealer in the morning but very strange. I was hitting the manual shifter hard yesterday testing the limits.... maybe I set something off doing that. Nothing found on this forum during my search nor the internet other than going back to 2012/13 on durangos and jeeps. I'm going on a long trip in 2 weeks and concerned about a potential failure...... and being 2k miles away in AZ, failure's not an option. LOL Hopefully a flash w/ any updates overall will correct. I was hoping someone might have info on this. Thanks
     
    Ruben lopez likes this.
  2. DJ2010RT

    DJ2010RT Old School Look! Site Supporter Level 3 MOTM Winner! Public Safety

    Joined:
    Jul 24, 2010
    Messages:
    2,727
    Media:
    37
    Albums:
    6
    Likes Received:
    1,458
    Gender:
    Male
    Location:
    Florida Keys
    Vehicle?:
    2014 Challenger
    Model Year?:
    2014
    Trim?:
    R/T Classic
    Color?:
    Granite Crystal
    Transmission?:
    6-Speed
    I hope it is something simple. That sucks to be going on a trip and have unknown issues. I have not heard anyone talk about the issue you are describing. I can't speak to it because I have the 6-speed. Please let us know what happens.
     
    Ruben lopez likes this.
  3. Bee Keeper 16

    Bee Keeper 16 Aspire to inspire before we expire. Site Supporter Level 2 Site Supporter Level 1 Member Relations MOTM Winner! Public Safety

    Joined:
    Nov 1, 2015
    Messages:
    6,130
    Likes Received:
    7,025
    Gender:
    Male
    Location:
    Northern Colorado
    Vehicle?:
    Challenger
    Model Year?:
    2016
    Trim?:
    R/T Scat Pack Shaker
    Color?:
    Plum Crazy
    Transmission?:
    8-Speed Auto
    I am not having this problem. I am curious to your outcome.
     
    Ruben lopez likes this.
  4. silverhorse

    silverhorse Member

    Joined:
    Sep 7, 2009
    Messages:
    319
    Likes Received:
    258
    Gender:
    Male
    Location:
    Grand Rapids, MI
    Vehicle?:
    SRT 392
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto
    Ok.... update:

    1) Error code "Shifter service" visual only code read/translated into..... replace shifter mechanism mount on floor (Not the shifter knob/stem)
    2) Mechanic replaced but message popped up here and there again only now with an audible ding ding. Ordered new shifter Handle to see if that works. Mechanic surprised as the knob only has LED lighting with no other parts/mechanism but thinks.... let's try that anyway. He calls Detroit but they have no explanation either.
    3) Mechanic stated not to worry as it won't fail me as is. So I drive to AZ and attend SRT race school last Saturday waiting for part to come in.
    4) Came back with no issues. Shift knob now replaced as of Tuesday...... no error messages as of yet.

    I will update if the problem persists. Hopefully it's fixed and was a one off fluke for me only and no one else has this problem.... but if so, I hope this will help anyone else who may get the same message.
     
    Ruben lopez likes this.
  5. Othman

    Othman New Member

    Joined:
    May 21, 2017
    Messages:
    4
    Likes Received:
    7
    Gender:
    Male
    Location:
    Dubai, United Arab Emirates
    Vehicle?:
    Challenger
    Model Year?:
    2015
    Trim?:
    SXT Plus
    Color?:
    Black
    Transmission?:
    6-Speed
    You are the reason i've signed up over here!

    I've got a Challenger 2015 V6

    I have to admit it's way so fast compared to my older V8 5.7 2013

    I have not single idea how

    Anyways, my issue is similar to yours, it's the error in the hud that gives Shifter Service, it doesn't stay there, but I get more to come, the torque of the car goes down, the rpm goes to maximum 2500 then goes so difficult to change the gear..

    It's an Automatic shift obviously, but the issue is there, I have to remove the battery, put it back, then it works fine..

    One more issue along with it, when I put the gear into manual position, I can't go back to First gear, it starts at Second gear!

    Did you have a similar issue, & is your car all good after changing the Shift Knob ?


     
    Ruben lopez likes this.
  6. silverhorse

    silverhorse Member

    Joined:
    Sep 7, 2009
    Messages:
    319
    Likes Received:
    258
    Gender:
    Male
    Location:
    Grand Rapids, MI
    Vehicle?:
    SRT 392
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto
    Yes...... Once the mechanic changed the actual handle it all worked fine and has been for many months. Strange that a shifter handle with only an LED light inside would throw the code vs the actual shifter which had a wiring harness, etc . In your case it sounds like your code may be putting your car in "Limp Mode" designed to get you home (Reduced Power) but not further damage components. If you have a "Shifter Service" code get both replaced (Shifter and Handel). Hope all works out.
     
    Ruben lopez likes this.
  7. silverhorse

    silverhorse Member

    Joined:
    Sep 7, 2009
    Messages:
    319
    Likes Received:
    258
    Gender:
    Male
    Location:
    Grand Rapids, MI
    Vehicle?:
    SRT 392
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto

    Oh and thank you for the kind words..... great forum here.
     
    Ruben lopez likes this.
  8. Othman

    Othman New Member

    Joined:
    May 21, 2017
    Messages:
    4
    Likes Received:
    7
    Gender:
    Male
    Location:
    Dubai, United Arab Emirates
    Vehicle?:
    Challenger
    Model Year?:
    2015
    Trim?:
    SXT Plus
    Color?:
    Black
    Transmission?:
    6-Speed
    Well i'm a member now, there is no way I can run away, oh & besides, i have a Challenger, this is my home already !

    I don't really know if they would understand this issue over here in Dubai, anyways, i'll check it out with the mechanic to see what we can do with it, Shifter & Handle it is, i'll pass that to the mechanic !

    Btw, Thanks a lot for replying, I never thought I'd get a reply from a very old post, it's almost 1 year for this post!



     
    Ruben lopez likes this.
  9. Ruben lopez

    Ruben lopez New Member

    Joined:
    Jul 12, 2017
    Messages:
    1
    Likes Received:
    0
    Gender:
    Male
    Location:
    Houston
    Vehicle?:
    Dodge Challenge
    Model Year?:
    2015
    Trim?:
    SXT Plus
    Color?:
    TorRed
    Transmission?:
    8-Speed Auto
    Hey man I have the same message, but I have no problems with the car It drives normal, where can I buy that part? Thanks
     
  10. silverhorse

    silverhorse Member

    Joined:
    Sep 7, 2009
    Messages:
    319
    Likes Received:
    258
    Gender:
    Male
    Location:
    Grand Rapids, MI
    Vehicle?:
    SRT 392
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto
    You will have issues eventually. Contact any Dodge Parts dealer and try swapping out the actual hand shifter first. If that doesn't work then the actual shifter mechanism that the shifter attaches to. Save money that way.
     
  11. 12SRT8YJ

    12SRT8YJ Member Military Public Safety

    Joined:
    Feb 4, 2016
    Messages:
    865
    Media:
    14
    Likes Received:
    1,015
    Gender:
    Male
    Location:
    Fairborn, OH
    Vehicle?:
    Scat SHAKER
    Model Year?:
    2016
    Trim?:
    R/T Scat Pack Shaker
    Color?:
    Redline Red
    Transmission?:
    6-Speed
    I have the "Service Shifter" message at start up with only 356 miles. Lights in the shift handle are out as well.
     
  12. silverhorse

    silverhorse Member

    Joined:
    Sep 7, 2009
    Messages:
    319
    Likes Received:
    258
    Gender:
    Male
    Location:
    Grand Rapids, MI
    Vehicle?:
    SRT 392
    Model Year?:
    2016
    Trim?:
    SRT-8
    Color?:
    Redline Red
    Transmission?:
    8-Speed Auto
    It's the top handle only.... glad it's under warranty
     
  13. 12SRT8YJ

    12SRT8YJ Member Military Public Safety

    Joined:
    Feb 4, 2016
    Messages:
    865
    Media:
    14
    Likes Received:
    1,015
    Gender:
    Male
    Location:
    Fairborn, OH
    Vehicle?:
    Scat SHAKER
    Model Year?:
    2016
    Trim?:
    R/T Scat Pack Shaker
    Color?:
    Redline Red
    Transmission?:
    6-Speed
    Yup, parts on order through dealer.
     

Share This Page