Dodge Challenger Forum banner
21 - 32 of 32 Posts

·
Registered
Joined
·
8 Posts
sweaver123 described my experience last weekend with one exception. Sunroof stuck open, open and close rockers were unresponsive. The vent button allowed me to inch it closed with several stabs at the button and ended up stuck in the "vent" position. I let the car sit for 30 minutes or so and restarted. I hit the "open" button and the roof stopped at the 1/2 way point. Based on the post by 426 I was thinking a calibration issue. I held the vent button down for about 10s, released and then hit the close. Works fine now but I certainly will not be surprised to see this happen again. This was the warmest day my car has been exposed to since delivered (80 deg external). Possible factor/trigger?
 

·
Registered
Joined
·
3 Posts
has anyone had any sunroof issues? i went to open the vent by using the middle button today , and it just went up about 1/2" and stopped and i tried it again and it did the same thing, then it would not do anything but click.parked the car and shut it off for about 10 minutes and it worked fine.was this just a fluke or has anybody else had this issue?
thanks, marada
I let mine sit in the garage for an hour, then started it, and the sunroof worked like a champ.
 

·
Registered
Joined
·
194 Posts
my sunroof is currently stuck in the vent position. im having all the same issues everyone else has described (clicking with no movement). i have a 2012 srt8 with 27,000 miles over a year and a half. this is the first time this has happened and hopefully the last. im hoping the letting it sit for a little bit trick will work for me too.
 

·
Registered
Joined
·
614 Posts
my sunroof is currently stuck in the vent position. im having all the same issues everyone else has described (clicking with no movement). i have a 2012 srt8 with 27,000 miles over a year and a half. this is the first time this has happened and hopefully the last. im hoping the letting it sit for a little bit trick will work for me too.
Yep, had the same happen to me on my 2013 R/T. Stuck in the vent position, after sitting for about 10 minutes with the car off it started working again and have not had the problem again. We shall see........
 

·
Registered
Joined
·
194 Posts
Yep, had the same happen to me on my 2013 R/T. Stuck in the vent position, after sitting for about 10 minutes with the car off it started working again and have not had the problem again. We shall see........

well after letting it sit for about a hour i went back outside and dtarted her up and tried to close the sunroof and nothing. remembered reading about how to recalibrate it and tried that. after holding down the vent button for 10 seconds i released and pushed the close button and it worked again. tried opening and closing the sunroof several times and it still works. i really hope this doesnt happen again, it was a simple fix this time but next time who knows.....
 

·
Registered
Joined
·
4,321 Posts
Info by 426 is spot on - try the recalibration procedures as needed - works every time for me. Btw, the home weblink tip #118 is found on has lots of great info about a lot of things - highly recommend you book mark it!

I've had this happen to me a few times. I finally figured out the common thread was creating multiple electrical loads (windows, radio, NAV, sunroof, etc) at the same time you are either shutting off the car, or your are starting the car and the car self check diagnostics havent completed (less than a second). Once I figured that out and took care of business before shutting off the car (or waited a second after starting the car), the problems went away. On some cars, you might also experience the same thing with the Radio/Nav system. For example, if you hit the CD open/close just after you've started the car and the system hasn't completed its boot up, it might accept the CD you've stuck but not be able to read it. Other gremlins can occur too. All of them going away after letting it sit in the off position for a time and letting the re-start procedure fully boot up and clear the diagnostic errors out.

If you have a second or two of patience to make sure everything is up and running before you do multiple electrical tasks, it does the trick - at least for me it did :)

Reps to 426 for the link post!
 

·
Registered
Joined
·
576 Posts

·
Honey Badger don't give a $#|£
Joined
·
299 Posts
Left mine in the vent open position just yesterday, all day. Temp was about 78 degrees outside. Went to jump in and close it and just got the clicking sound. Ran right down to the dealer and set up an appointment for the next morning. After leaving the car no more than 10 minutes while I spoke with the service guy it worked fine. Nobody having this happen more than once? Sure seems wierd...
Im on my 2nd time and its not going down
 
21 - 32 of 32 Posts
Top