Dodge Challenger Forum banner

1 - 4 of 4 Posts

·
Administrator
2016 Challenger Scat Pack Shaker
Joined
·
49,525 Posts
Discussion Starter #1
I am asking for a friend. He has a 17 Scat Pack and the other day he went to use his wipers, well actually the washers which turns the wipers on and the wipers did not work. He checked the relay and it was blown so he replaced the relay and it blew again. So there is a short somewhere either the motor the switch or in the wiring. I searched here and the Charger forum for similar issues but could fine none. Has anybody heard of this problem. He is out of warranty but has some aftermarket warranty so I don't know if it will be covered.
 
  • Like
Reactions: Kustom1950ford

·
Administrator
2016 Challenger Scat Pack Shaker
Joined
·
49,525 Posts
Discussion Starter #3
Wiring issues suck. If he could unplug the motor and put another fuse in to see if it blows unplugged. Just start doing the process of elimination!
It does not blow until the switch is turned on.
 

·
Registered
2016 Dodge Challenger R/T Plus in Granite Crystal Metallic
Joined
·
1,639 Posts
It does not blow until the switch is turned on.
You have to eliminate the device in which the switch powers up first. Do the wipers work if the spray function isn't used? Like the other member indicated, unplug the pump and see if the fuse blows when the switch is placed in the 'ON' position. If it doesn't then the pump is the issue, if it does, then disconnect the wipers, if it doesn't blow then the wipers are the issue, if it does then it's a wiring issue. Electrical shorts are a PITA but with patience and a sound method it could be an easy fix.
 
1 - 4 of 4 Posts
Top